Configuring Cisco Nexus N3K C3064PQ 10GX Cisco Nexus 3000

Published: February 25, 2022

Last Modified: February 20, 2023

Configuring Cisco Nexus N3K C3064PQ 10GX Cisco Nexus 3000

The switch has 48 SFP+ 10 Gb/s and 4 QSFP+ 40 Gb/s ports

When connecting for the first time through the console, specify the password for the admin user:

Do you want to enforce secure password standard (yes/no): yes
  Enter the password for "admin":
  Confirm the password for "admin":
  Would you like to enter the basic configuration dialog (yes/no): no

Switch to configuration mode and specify the firmware file:

configure terminal
show incompatibility nxos bootflash:nxos.7.0.3.I4.6.bin
boot nxos bootflash:/nxos.7.0.3.I4.6.bin
exit

Save the configuration and reboot the switch:

copy running-config startup-config
 reload
This command will reboot the system. (y/n)?  [n] y

Next, we look at the current and saved configuration:

show running-config
show startup-config

During switching on the switch, if necessary, you can switch to bootloader mode:

Press  ctrl L to go to loader prompt in 2 secs

From the bootloader, you can also manually start the switch with the specified firmware:

loader>boot bootflash:nxos.7.0.3.I4.6.bin

Or like this:

switch(boot)#load bootflash:nxos.7.0.3.I4.6.bin

Select the ports mode, and after this action you need to restart the cat:

hardware profile portmode ?

hardware profile portmode 48x10g+4x40g
hardware profile portmode 52x10g+3x40g
hardware profile portmode 56x10g+2x40g
hardware profile portmode 60x10g+1x40g
hardware profile portmode 64x10g
exit
reload

Add the necessary VLANs and, if necessary, descriptions:

vlan 100
name Management
vlan 200
name Users
exit

Configuring access and trunk ports:

interface Ethernet1/46
switchport
switchport mode access
description disnetern
switchport access vlan 200
storm-control broadcast level 0.50
interface Ethernet1/44
switchport
switchport mode trunk
switchport trunk allowed vlan 100,200

Configuring a hybrid port, Vlan 100 without a tag, and all other vlans with a tag:

switchport mode trunk
  switchport trunk native vlan 100
  switchport trunk allowed vlan 300-400,100

By default, ports 1-48 are configured for 10 Gb / s, to connect 1 Gb / s you need to specify:

interface ethernet 1/1-20
speed 1000
interface ethernet 1/21-48
speed 10000

Time zone and ntp server for time synchronization:

ntp server 10.5.103.20
clock timezone UTC 3 0
show clock

Set up SNMP:

snmp-server community blabla ro

If interface vlan (SVI) will be created, then you need to activate feature interface-vlan:

how feature
feature interface-vlan

Create an interface vlan (SVI)

vlan 100
exit
interface vlan 100
description support
ip address 172.20.1.5/24
ip address 10.5.100.5/24 secondary
no ip redirects
no shutdown
exit

Default route:

ip route 0.0.0.0/0 172.20.1.1

Or:

vrf context default
ip route 0.0.0.0/0 172.20.1.1

Setting mgmt port:

int mgmt 0
ip address 192.168.100.10/24
exit
vrf context management
ip route 0.0.0.0/0 192.168.100.1
exit
ping 192.168.100.55 vrf management

You can specify hostname:

hostname nexus

show version
show system uptime
show system resources
show boot variables
show banner motd
show feature
show vdc membership
show running-config copp all
show running-config interface ethernet 1/1-10
show interface ethernet 1/1 transceiver details
show interface ethernet 1/1-10
show interface status
show interface brief
show interface Ethernet1/52
show interface Ethernet1/52 brief
show processes cpu
show processes log
show processes log details
show processes memory
show logging
show cli history
show install all status
dir
show sprom all
show inventory
show module
show environment
show environment power
show environment fan
show environment fan detail
show environment temperature
show license
show system reset-reason
show terminal

Uptime :

show version

Allow the use of SFP modules from third-party manufacturers:

service unsupported-transceiver

When using third-party SFP and DAC cables, you can specify the commands below for the interfaces, since without them there was either no link or it disappeared after a while, for example:

interface ethernet 1/52
no negotiate auto
duplex full

You can also turn off flow-control if it didn’t turn off automatically:

no flowcontrol receive
no flowcontrol send

Set console sessions to end after 30 minutes:

line console
exec-timeout 30

An example of restricting access to the switch by IP addresses:

ip access-list manage
permit ip 10.100.5.1/32 any
permit ip 192.168.100.5/32 any
line vty
exec-timeout 30
access-class manage in

telnet activation:

feature telnet

To clear the configuration, use the command:

write erase

An example of copying the current and saved configuration to a TFTP server:

copy running-config tftp://disnetern.ru/running-config.bak
copy startup-config tftp://disnetern.ru/startup-config.bak

An example of restoring a configuration from a TFTP server:

copy tftp://disnetern.ru/running-config.bak running-config

See Also :