#1 Setting the Time on a Mikrotik Router, Easy Method

Published: December 28, 2022

Last Modified: February 26, 2023

Step-by-Step Guide to Setting the Time on a Mikrotik Router

To set the time on a Mikrotik router, you will need to use the Mikrotik RouterOS command line interface (CLI). Here are the steps to set the time on a Mikrotik router:

  • Connect to the Mikrotik router using a terminal emulator program such as PuTTY.

  • Log in to the router using the administrator username and password.

  • Enter the following command to set the timezone for the router:

/system clock set time-zone-name="timezone" 

Replace “timezone” with the appropriate timezone for your location. For example, to set the timezone to Eastern Standard Time (EST), you would use:

/system clock set time-zone-name="EST" 

  1. Enter the following command to set the date and time for the router:

/system clock set date=date time=time

Replace “date” with the current date in the format YYYY-MM-DD and “time” with the current time in the format HH:MM:SS. For example, to set the date to January 1, 2022 at 12:00:00, you would use:

/system clock set date=2022-01-01 time=12:00:00

  1. If you want the router to automatically synchronize its time with an NTP (Network Time Protocol) server, you can use the following command:

/system ntp client set enabled=yes primary-ntp=ntp.server.name 

Replace “ntp.server.name” with the hostname or IP address of an NTP server. Some popular ones include:

  1. time.nist.gov
  2. time.windows.com
  3. pool.ntp.org

  1. To save your changes and apply them, use the following command:

system clock save

That’s it! You have successfully set the time on your Mikrotik router.

Alternatively, you can use the Winbox graphical user interface (GUI) to set the time and timezone on the router. To do this, follow these steps:

  • Open Winbox and connect to the Mikrotik router.
  • In the left-hand menu, click on the “System” tab and then select the “Clock” sub-tab.
  • In the “Time Zone” field, select the appropriate timezone for your location from the drop-down menu.
  • In the “Date and Time” fields, enter the current date and time.
  • If you want the router to automatically synchronize its time with an NTP (Network Time Protocol) server, select the “Enabled” checkbox in the “NTP Client” section and enter the hostname or IP address of an NTP server in the “Primary NTP” field.
  • Click the “Apply” button to save your changes.

That’s it! You have successfully set the time on your Mikrotik router using the Winbox GUI.

Read Also :